一周注册机速成代码篇-写个猜数字的小游戏

发布于 2020-04-16  467 次阅读


.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 C, 整数型

.子程序 __启动窗口_创建完毕

' A,B,C 三个人
' C 是裁判, 判断A,B说的数字大了或者是小了。 同时C还要在心中想一个数字
' 游戏结束: A,B 猜中了数字
C = 100

.子程序 _按钮1_被单击
.局部变量 数字, 整数型

数字 = 到整数 (编辑框1.内容)

.判断开始 (数字 > C)
    信息框 (“啊哦,数字大了”, 0, , )
.判断 (数字 < C)
    信息框 (“啊哦,数字小了”, 0, , )
.默认
    信息框 (“恭喜您~正确啦~~~”, 0, , )
.判断结束




.子程序 _按钮2_被单击

置随机数种子 ()
C = 取随机数 (1, 100)
信息框 (“游戏重新开始啦~~”, 0, , )