一周注册机速成代码篇-99乘法表

发布于 2020-04-16  475 次阅读


.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 i, 整数型
.局部变量 j, 整数型
.局部变量 结果, 文本型

.计次循环首 (到整数 (编辑框2.内容), i)

    .计次循环首 (i, j)
        结果 = 到文本 (j × i)
        .如果真 (取文本长度 (结果) ≠ 2)
            结果 = 结果 + “ ”
        .如果真结束

        编辑框1.加入文本 (到文本 (j) + “×” + 到文本 (i) + “=” + 结果 + “ ”)

    .计次循环尾 ()
    编辑框1.加入文本 (#换行符)

.计次循环尾 ()


' 1x1=1
' 1x2=1   2x2=4
' 1x3=2   2x3=6  3x3=9